- Feature Articles
- CodeSOD
- Error'd
- Forums
-
Other Articles
- Random Article
- Other Series
- Alex's Soapbox
- Announcements
- Best of…
- Best of Email
- Best of the Sidebar
- Bring Your Own Code
- Coded Smorgasbord
- Mandatory Fun Day
- Off Topic
- Representative Line
- News Roundup
- Editor's Soapbox
- Software on the Rocks
- Souvenir Potpourri
- Sponsor Post
- Tales from the Interview
- The Daily WTF: Live
- Virtudyne
Admin
if isIntentegerInRange(1, 1, 1) print frist
Admin
isNull("WTF?") == isNotNull("WTF?");
Admin
I never thought I'd see a function that implies a boolean return value simply return the hex code for red as a string. Mind boggling.
Admin
Admin
You forgot the result:
public static boolean isCommentnteFrist(String commentnte) {
}
Admin
An intenteger is for when you really mean that one number.
Admin
Admin
I use intentegers all the time intententionally.
Admin
This sort of code is like a recurring nightmare. I can't even count the number of times I've seen this crap before and it's a foregone conclusion that I'll see it again. Note to HR: stop hiring these people FFS! You are the reason we must suffer these fools!
Admin
Yeah, I choked when I saw that.
Admin
I see your confusion, but apparently you haven't worked with nte methods before, or with the Integernte framework. Any experienced retarded developer knows that, right!
Just for clarity:
public static boolean isCommentnteFrist(String commentnte) {
}
public static boolean isCommentFrist(String commentnte) {
}
Obviously any RetardedDeveloperException ultimately causes one of your CPU cores to be used for melting marshmallows by chipmunks on LSD.
Admin
It's not an additional "nte" it's an additional "ent", made to work on trees.
Admin
Correct handling policy pattern for RetardedDeveloperException:
Admin
Oh cool, I just added this to my code repository.
... the RetardedDeveloperException.
Admin
Aren't these more likely? It checks a string against the range.
Admin
First code snippet for a long time where every function along the way all I could think to myself was [image]
Admin
Good man. Just make sure it handles FILE_NOT_FOUND correctly.
Admin
Admin
I don't see the WTF. As far as I can see, this developer is ahead of all of us. Who among us could write a method that checks not the integer that we pass in, but the integer that we intended to pass in? This is an ESP library. I'm in awe.
Admin
Oh sorry, must have misread that.
Never liked the ent framework, reminds me too much of Hobbit++ not to mention ring buffers and ELF-Eventhandling.
Admin
And yet... isNull(x) == isNotNull(x). That can't be good.
Admin
In these politically correct days, of course, we must:
And, of course, retarded developers aren't new:
abbas: Mediaeval Latin abbot, Arabic name, etc.
[2]
Admin
Thank you dailywtf for confirming once again that whatever happens, I'll never write code as bad as an isEmpty function that returns either an empty string or the hex code for red. Thank you for reaffirming my belief in myself.
Admin
Admin
The Tao master once explained the nature of x to a young student.
"Is x Null?" asked the Student.
"Is x not Null?" asked the Master in turn.
The Student was enlightened.
Admin
Admin
isIntegerInRante("1",1,1) would at least compile.
Admin
RTFA!!! It is clearly 0xFF0000.
Admin
Null is the value that is not a value. To ask what it's value nature is is to deny its Null nature, and yet it is a value nonetheless. Compare with NaN in IEEE floating point.
Admin
I'm implementing this in my code, I think it's grand.
public bool IsTrue(boolean TrueOrFalse) { bool Error = false; if(TrueOrFalse == true) { Error = false; } return Error; }
but it didn't seem to work right, so I made another public bool IsTrue(boolean TrueOrFalse) { bool Error = false; if(TrueOrFalse.ToString().ToUpper() == "TRUE") { Error = true; } return Error; }
this one seems to work better.
;)
Admin
I read "public sad String isNull()" Poor, public, sad, static function :(
Admin
Clearly? You are so terribly mistaken, retarded developers use Hexentdecimal addressing. The first occurrence of a retarded developer might more likely be at 0xWTF001FRIST42. Although that one might be on a crack pipe...
Admin
if( isNull(x) == isNotNull(x) ) print("this is a quantum computer");
Admin
Missed that. Surely it should be isStrintegerInRange? (and isStrintentegerInRange for the differently abled)
Admin
Clearly it's supposed to be "in-ten-tegers" because you know some number systems go up to 11.
Admin
Maybe they forgot to mention the programmer was only 9 years old and got his job the old fashion way (nepotism).
Admin
=D That's funny... And kind of ironic
Admin
You hurt codes feelings, code is sad =(
Admin
Same here, I wonder if FreeBSD dev is willing to mentor me in implementing said exception in C...
Admin
on second thought, that code hurts my head way too much and I need coffee. WTG retard coder (Monkey at keyboard?)!
Admin
Admin
I prefer this:
if isIntentegerInRange(1.ToString(), 1, 1){}
Admin
if isInTENTegerInRange(1, 1, 1) //To Do: Come up with witty comment about Irish Girl
Admin
I saw this code the other day from a developer who thought he was clever for using ternary syntax:
$myBooleanValue = ($param==1)?"true":"false";
The best part? He justified it because the code someone else had written was expecting a string value of "true" or "false" for $myBooleanValue.
Admin
This is one of the better ones I've seen lately.
A seemingly-boolean function that returns the hex code for red? A function with a parameter named "integer" that is actually a String?
Admin
This isn't enterprisey enough.
IntegerRangeFinderFactory f = new IntegerRangeFinderFactory("pie", 27, new Thing()); IntegerRangeFinder rf = f.getIntegerRangeFinder("left", "KHAN!!!"); if(rf.createIntegerRangeFinderFinder().finder().cleft().isIntentegerInRange(IntegerStringMakerDoohickeyMaBob.parseTheFrackinIntegerIntoaString(1), 1, 1) { try { throw moreCode(); } catch(NotEnoughCodeException e) { throw new RetardedDeveloperException(e, "Lies!"); } finally { stillNotEnoughCode(moar_code_plx, DailyWTF.WOODEN_TABLE); } }
Admin
Admin
I think this is my favourite wtfery ever. Every little wtf is like a tiny hidden gem - I have to go over each method again and again to find all the things that my brain refused to acknowledge last time, they're just so gorgeously horrific. /me reads it again...
Addendum (2009-11-02 11:11): I love that the isEmpty method returns a string, and you have to check whether it's returned the empty string, to find out if your first string was empty.
Admin
That looks like hangover code.
Admin
Whenever i start a new job i am faced with a huge collection of wtfs faulty design and crappy code.
Fortunately for me, i think amongst the wost thing i saw was: String doSomeAction(SomeClassType someObject){ try{ return SomeObject.DoSomeAction(); } catch (NullPointerException e){ return null; }
}
bad, i know , wtf - i know..but its no where near as bad as String green="#00FF00"; if (isNull(green)) { green = isEmpty("","event"); //green might have been set to red, but fortunately isNull will return false... }
green = null;
if (isNotNull(green)) { green = isEmpty(green,"notNullEvent"); //at this point we'd have a null pointer exception... //good thing we made sure our string is not null. }